Originally BIGACE was created to be used with the Apache Webserver, but community members also run it successfully with the LightHttpd Webserver and the Microsoft IIS (both support URL rewriting as well).

As BIGACE is written in PHP and for a MySQL backend, both of them are mandatory.


  • PHP version 5.3 or greater
    • memory_limit >= 24 MB RAM
    • modules: mysqli or PDO, XML, SimpleXML
    • optional modules: GD, ZIP
  • MySQL version 5 or greater
  • 30 MB webspace for installation
  • Recommended: Apache mod_rewrite

BIGACE 2.5 - 2.7

  • PHP version 5.1 or greater (required modules: mysql, XML, SimpleXML)
  • MySQL version 4.1 or greater
  • PHP Setting: memory_limit >= 12MB RAM


  • GD Lib for automatic thumbnails
  • .htaccess support and Apaches mod_rewrite module for SEO friendly URLs


  • PHP version 4.1 or greater (required modules: mysql, XML)
  • MySQL version 4.0 or greater

Ask your hoster

Copy and paste this letter to ask your hoster for BIGACE compatibility:

I'm interested in running the BIGACE <> content-management software and I was wondering if my account supports the following:

  • PHP 5.3 or greater
  • MySQL 5 or greater
  •  Apache "mod_rewrite" module
  • .htaccess Rewrite Rules


Fork me on GitHub